const regex = /^((?!ESMTPS|ESMTPA).)*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((?!ESMTPS|ESMTPA).)*$', 'gm')
const str = `Received: from shvf13.jpmchase.com (shvf13.jpmchase.com [159.53.46.159]) by mydomain.net with ESMTPS (version=TLSv1.2 cipher=ECDHE-RSA-AES256-GCM-SHA384 bits=256) ; Fri, 25 Dec 2020 06:06:57 -0500`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}