using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"'([^']+)':\(";
string input = @"'hello there':(
'more text':(
'she said \'hello\'':( <-- will not work, see Assumption 1
'hello' enough? :( <-- will not work, see Assumption 2";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}