$re = '/\'([^\'\\\\]*(?:(?:\\\\.)[^\'\\\\]*)*)\'/m';
$str = 'It was \'He said \\\'hello\\\' to her\' not the other way around.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);