# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((?: |^)([\p{L}\p{M}])\2+(?= |$))|([\p{L}\p{M}])(?=\3)/$1/gu;t' <<< "aaa baaab xxx
ahhj aaab cc iiik
bbb ahhj aaab cc iiik xxx fjjj baaaaaab yyyaaa
#$aa$aa#aaa bbb
aaa aaa
test aaaaa aaaaa aaaa
aaa aaa d$test#dd!aaaa$ddd !dd#fdg5$hhaaa^%bb zzzzz
ááá áább çç ççç ábbá"