import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(([^<>()\\[\\]\\.,;:\\s@\\\"]+(\\.[^<>()\\[\\]\\.,;:\\s@\\\"]+)*)|(\\\".+\\\"))@(([^<>()\\.,;\\s@\\\"]+\\.{0,1})+([^<>()\\.,;:\\s@\\\"]{2,}|[\\d\\.]+))";
final String string = "- VALID MAILS\n\n"
+ "Abc@example.com\n"
+ "Abc@example.com.\n"
+ "Abc@10.42.0.1\n"
+ "user@localserver\n"
+ "Abc.123@example.com\n"
+ "user+mailbox/department=shipping@example.com\n"
+ "\"very.(),:;<>[]\\\".VERY.\\\"very@\\\\ \\\"very\\\".unusual\"@strange.example.com\n"
+ "!#$%&'*+-/=?^_`.{|}~@example.com\n"
+ "\"()<>[]:,;@\\\\\\\"!#$%&'-/=?^_`{}| ~.a\"@example.org\n"
+ "\"Abc@def\"@example.com\n"
+ "\"Fred Bloggs\"@example.com\n"
+ "\"Joe.\\\\Blow\"@example.com\n"
+ "Loïc.Accentué@voilà.fr\n"
+ "\" \"@example.org\n"
+ "user@[IPv6:2001:DB8::1]\n\n"
+ "- INVALID MAILS\n\n"
+ "Abc.example.com\n"
+ "A@b@c@example.com\n"
+ "a\"b(c)d,e:f;g<h>i[j\\k]l@example.com\n"
+ "just\"not\"right@example.com\n"
+ "this is\"not\\allowed@example.com\n"
+ "this\\ still\\\"not\\\\allowed@example.com\n"
+ "john..doe@example.com\n"
+ "john.doe@example..com";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}