$re = '/(?=(?:\D*\d\D*){8,14}$)[- \d()+]*/m';
$str = '01 02 03 04 05
0102030405
+33102030405
01-02-03-04-05
01.02.03.04.05
+33 1 02 03 04 053
(+33)102030405';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);