# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^([^XY]*)(Y)([^X]*)$|(.*)(X)/\1\41\3\5\2/gm;t' <<< "abcde
abcXe
abcdY
abcXY
abYcXY
abcYX"