package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([^XY]*)(Y)([^X]*)$|(.*)(X)`)
var str = `abcde
abcXe
abcdY
abcXY
abYcXY
abcYX`
var substitution = "\1\41\3\5\2"
fmt.Println(re.ReplaceAllString(str, substitution))
}