import Foundation
let pattern = #"^([^XY]*)(Y)([^X]*)$|(.*)(X)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
abcde
abcXe
abcdY
abcXY
abYcXY
abcYX
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1\41\3\5\2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)