re = /(?<![a-zA-Z])(?=([a-zA-Z]+\d+[a-zA-Z]+))/m
str = 'a123123aas52342ooo345345ooo'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end