# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\\u([a-z0-9]+)/\\x{$1}/gi;t' <<< "\u302D"