use strict;
my $str = '\\u302D';
my $regex = qr/\\u([a-z0-9]+)/ip;
my $subst = '\\\\x{$1}';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";