use strict;
my $str = 'https://www.traveloka.com/en-id/hotel/indonesia/1o1-urban-jakarta-kelapa-gading-461890?spec=25-11-2023.26-11-2023..1.HOTEL.461890..1¤cy=IDR&contexts=%7B%22sourceHotelDetail%22%3A%22HOTEL_POPULAR_WEB%22%7D';
my $regex = qr/https?:\/\/(?:www\.)?traveloka\.com\/en-id\/((?!.*activities.*).*)/p;
if ( $str =~ /$regex/ ) {
  print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
  # print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
  # print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}