import Foundation
let pattern = #"https?:\/\/(?:www\.)?traveloka\.com\/en-id\/((?!.*activities.*).*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"https://www.traveloka.com/en-id/hotel/indonesia/1o1-urban-jakarta-kelapa-gading-461890?spec=25-11-2023.26-11-2023..1.HOTEL.461890..1¤cy=IDR&contexts=%7B%22sourceHotelDetail%22%3A%22HOTEL_POPULAR_WEB%22%7D"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}