// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)Example\s+(\d+):(?:.*?(ERROR)|.*)").unwrap();
let string = "Example 1: bla bla bla
Example 2: bla bla ERROR
Example 3: bla bla
Example 4: bla bla ERROR bla bla";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}