$re = '/\bpayments\W+(?:\w+\W+){1,9}?(?<highlight>\d{1,3})\s+?days\b/m';
$str = 'Lorem ipsum dolor sit amet, consectetur adipiscing elit. Maecenas at neque eu felis rutrum efficitur. Pellentesque lacinia mauris metus, at dapibus ante varius non. Maecenas non pulvinar velit. Class aptent taciti sociosqu ad litora torquent per conubia nostra, per inceptos himenaeos. Fusce ut risus sollicitudin, interdum dolor condimentum, hendrerit nibh. Donec efficitur sem nisl, ut tristique mauris pulvinar eget. payments must be made within 60 days. Duis eu odio vitae turpis pulvinar placerat vulputate a diam. Maecenas eget risus mauris. Nulla ac convallis erat, a commodo velit. Fusce convallis ultrices neque. Etiam id urna lacus. Mauris fermentum tortor lacus, id congue dui suscipit vitae. Donec mi odio, laoreet a enim et, suscipit varius mauris. Nulla facilisi.--';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);