import re
regex = re.compile(r"\bpayments\W+(?:\w+\W+){1,9}?(?<highlight>\d{1,3})\s+?days\b", flags=re.MULTILINE)
test_str = "Lorem ipsum dolor sit amet, consectetur adipiscing elit. Maecenas at neque eu felis rutrum efficitur. Pellentesque lacinia mauris metus, at dapibus ante varius non. Maecenas non pulvinar velit. Class aptent taciti sociosqu ad litora torquent per conubia nostra, per inceptos himenaeos. Fusce ut risus sollicitudin, interdum dolor condimentum, hendrerit nibh. Donec efficitur sem nisl, ut tristique mauris pulvinar eget. payments must be made within 60 days. Duis eu odio vitae turpis pulvinar placerat vulputate a diam. Maecenas eget risus mauris. Nulla ac convallis erat, a commodo velit. Fusce convallis ultrices neque. Etiam id urna lacus. Mauris fermentum tortor lacus, id congue dui suscipit vitae. Donec mi odio, laoreet a enim et, suscipit varius mauris. Nulla facilisi.--"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")