$re = '/\w+(?: +\w+)+(?=\s*:\s*B)/';
$str = 'Ronald Mayr: A
Bell Kassulke : B
Simon Loidl: B
Надо сгенерировать список только тех, кто получил оценку В:
Bell Kassulke
Simon Loidl';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);