re = /\w+(?: +\w+)+(?=\s*:\s*B)/
str = 'Ronald Mayr: A
Bell Kassulke : B
Simon Loidl: B
Надо сгенерировать список только тех, кто получил оценку В:
Bell Kassulke
Simon Loidl'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end