use strict;
my $str = '[2024-04-27T03:36:48.026983+00:00] report.DEBUG: Hello World!';
my $regex = qr/^\[(?<timestamp>\d{4}-\d{2}-\d{2}T\d{2}:\d{2}:\d{2}.\d[^+]+\+\d{2}:\d{2})\]\s(?<channel>[^.]+).(?<level>[^:]+):\s(?<body>.*)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}