package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\w\d{2}-?\d{7}-?\d{7}`)
var str = `magnalister-Verarbeitung (Amazon)Marketplace Bestellnummer: 306-3584295-9664328** BUSINESS ORDER **Purchase Order Number: `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}