re = /\d{1,3}°\d{1,3}'\d{1,3}\.\d\"[N|S]\s\d{1,3}°\d{1,3}'\d{1,3}\.\d\"[E|W]/m
str = '73°10\'50.3"N 98°06\'02.9"W
36°10\'13.6"N 115°08\'23.6"W
115°10\'13.6"N 115°08\'23.6"W
36°101\'13.6"N 115°08\'23.6"W
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end