# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\.(?!\d)//g;t' <<< "a,b,a.b,a.,1,2,1.2,1.,.,11,222,11.222,11."