use strict;
my $str = 'a,b,a.b,a.,1,2,1.2,1.,.,11,222,11.222,11.';
my $regex = qr/\.(?!\d)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";