import Foundation
let pattern = #"\.(?!\d)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"a,b,a.b,a.,1,2,1.2,1.,.,11,222,11.222,11."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)