use strict;
my $str = '(?x) # extended mode
(?<!\\\\) # no escape in before paren
(?: # begine or end alternation noncap group
(?<begin>\\( # begining pattern paren
(?: # name/index/noncap alternation noncap group
(?<named>\\?\\< # named ?<name>
(?<name>[\\w][\\w\\d_]+) # capture name
>)| # end of name >
(?<indexed>(?!\\?))| # indexed capture group no following ? after paren
(?<nonecap>\\?[^<]) # other groups that dont capture no following < after paren
) # name/index/noncap alternation noncap group
)| # begining pattern end
(?<end>\\)) # ending paren ends group scope
)';
my $regex = qr/(?x:#sds
)
(?#sdsa)
#sda
(?x) # extended mode)
(?<!\\) # no escape in before paren)
(?: # begine or end alternation noncap group)
(?<begin>\( # begining pattern paren)
(?: # name/index/noncap alternation noncap group)
(?<named>\?\< # named ?<name>)
(?<name>[\w][\w\d_]+) # capture name)
>)| # end of name >)
(?<indexed>(?!\?))| # indexed capture group no following ? after paren)
(?<nonecap>\?[^<]) # other groups that dont capture no following < after paren)
) # name/index/noncap alternation noncap group)
)| # begining pattern end)
(?<end>\)) # ending paren ends group scope)
)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}