import Foundation
let pattern = ##"""
(?x:#sds
)
(?#sdsa)
#sda
(?x) # extended mode)
(?<!\\) # no escape in before paren)
(?: # begine or end alternation noncap group)
(?<begin>\( # begining pattern paren)
(?: # name/index/noncap alternation noncap group)
(?<named>\?\< # named ?<name>)
(?<name>[\w][\w\d_]+) # capture name)
>)| # end of name >)
(?<indexed>(?!\?))| # indexed capture group no following ? after paren)
(?<nonecap>\?[^<]) # other groups that dont capture no following < after paren)
) # name/index/noncap alternation noncap group)
)| # begining pattern end)
(?<end>\)) # ending paren ends group scope)
)
"""##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
(?x) # extended mode
(?<!\\) # no escape in before paren
(?: # begine or end alternation noncap group
(?<begin>\( # begining pattern paren
(?: # name/index/noncap alternation noncap group
(?<named>\?\< # named ?<name>
(?<name>[\w][\w\d_]+) # capture name
>)| # end of name >
(?<indexed>(?!\?))| # indexed capture group no following ? after paren
(?<nonecap>\?[^<]) # other groups that dont capture no following < after paren
) # name/index/noncap alternation noncap group
)| # begining pattern end
(?<end>\)) # ending paren ends group scope
)
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)