$re = '/^([a-zA-Z]{1,2}\d{1,2})\s{1,1}\*?(\d[a-zA-Z]{2})$/mi';
$str = 'm20 5qj
BS3 1JP
bs3 1jp
m5 8wa
m205qj
Bs31JP
CF10 1SA
CF10,1sa
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);