using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\S)(?:(?:https?|www)\S+|/+(?!\S))(*SKIP)(*F)|/";
string input = @"Color/Colour
American English/British English
https://usa.gov/about
www.gov.uk/about
/
/ / / /
////";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}