re = /(?<!\S)(?:(?:https?|www)\S+|\/+(?!\S))(*SKIP)(*F)|\//m
str = 'Color/Colour
American English/British English
https://usa.gov/about
www.gov.uk/about
/
/ / / /
////'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end