package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`'(.+[^ \t]+)'`)
var str = `'80 people like '80s music'?`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}