const regex = /^[^\s_]+_[^\s_]+\K_(?=\S*\.jpg$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^\\s_]+_[^\\s_]+\\K_(?=\\S*\\.jpg$)', 'gm')
const str = `123_456_789.jpg
3210_5325_aa.jpg
54321-0888_555_1111.jpg`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}