use strict;
my $str = '<FONT color=\'red\'>aaa-1/2</br>bbb-1/3</br>aaa-1/20</FONT>';
my $regex = qr/aaa(?=[^<]*<\/?br\s*\/?>)/mp;
my $subst = '<FONT face=\'monospace\' color=\'black\'>$&</FONT>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";