$re = '/([a-zA-Z]+\$ \d+,\d+)
|([a-zA-Z]+\$ (?:\d{1,3}\.)*\d{3},\d+)
/mi';
$str = 'R$ 0,0
R$ 0,009
R$ 1,000
R$ 0,0056
R$ 123,00
R$ 1234,00
R$ 1.000,00
R$ 10.000,06
R$ 100.000,00
R$ 1.000.000,00
R$ 10.000.000,00
R$ 100.000.000,00
R$ 1.000.000.000,00
R$ 10.000.000.000,00
R$ 100.000.000.000,00
R$ 100.000.000.000,00
R$ 1.000.000.000.000,00
R$ 100.000.000.000.000,00
R$ 1.000.000.000.000.000,00
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);