#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "[+-]?(?:\d+|\D{0}\.\d+)(?:\.\d+)?"
Local $sString = "string .001 or -.001 or +.001 or 1.00 or -1.00 or 213 or -213 or 123.132s1 this is rhobust 012"
Local $sSubst = "__"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)