# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[+-]?(?:\d+|\D{0}\.\d+)(?:\.\d+)?"
test_str = "string .001 or -.001 or +.001 or 1.00 or -1.00 or 213 or -213 or 123.132s1 this is rhobust 012"
subst = "__"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.