package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[a-zA-Z0-9]{6,8}|[a-zA-Z0-9]{10,12})$`)
var str = `thisisatest
thisisate
thisis
thisisatestforalongstring`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}