re = /^(?:[a-zA-Z0-9]{6,8}|[a-zA-Z0-9]{10,12})$/m
str = 'thisisatest
thisisate
thisis
thisisatestforalongstring'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end