// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:[a-zA-Z0-9]{6,8}|[a-zA-Z0-9]{10,12})$").unwrap();
let string = "thisisatest
thisisate
thisis
thisisatestforalongstring";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}