package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((([D]{1,4}|[M]{1,4}|[Y]{2}|[Y]{4})([D]{1,4}|[M]{1,4}|[Y]{2}|[Y]{4}))([D]{1,4}|[M]{1,4}|[Y]{2}|[Y]{4}))$`)
var str = `MMMMDDYY
MDYY
YYYYDDMM
MDYY
DDDDDYYYMM
OODDYYMM
YYDDMMPPPP`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}