package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\d{3}.\d{3}.\d{3}-\d{2}$`)
var str = `092.183.639-21`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}