$re = '/^[&.a-zA-Z>:+~,\h]+$/m';
$str = '// YES:
class
somethingSomething
&Class
&.class
input > input
& > &
~ class
> div
a, c
&.disabled:disabled:hover
// NO:
class-class
class--class
&-class
&--class
&__class';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);