use strict;
my $str = ' {2}|\\r\\n|[&(?!(#\\\\d+|\\\\w+);)<>\\r\\n\'"`]
&&& \' ; "< >
"http://www.example.com/?a=1&b=2&c=3/",
"Three in a row: &&&",
"< is <, > is >, ' is \', etc." handle numeric escapes, e.g.   – Jake Cobb Aug 3 \'16 at 19:55 ';
my $regex = qr/ {2}|\r\n|&(?!(#\d+|\w+);)|[<>\r\n'"`]/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}