re = / {2}|\r\n|&(?!(#\d+|\w+);)|[<>\r\n'"`]/
str = ' {2}|\\r\\n|[&(?!(#\\\\d+|\\\\w+);)<>\\r\\n\'"`]
&&& \' ; "< >
"http://www.example.com/?a=1&b=2&c=3/",
"Three in a row: &&&",
"< is <, > is >, ' is \', etc." handle numeric escapes, e.g.   – Jake Cobb Aug 3 \'16 at 19:55 '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end