package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<a href='(http:\/\/store\.steampowered\.com\/app\/\d+\/)'>`)
var str = `Today's Deal: Save 50% on <a href='http://store.steampowered.com/app/234270/'>Ken Follett's The Pillars of the Earth</a>!*<br><br>Look for the deals each day on the front page of Steam. Or follow us on <a href='http://twitter.com/steam_games'>twitter</a> or <a href='http://www.facebook.com/Steam'>Facebook</a> for instant notifications wherever you are!<br><br>*Offer ends Friday at 10AM Pacific Time<br><a href=\"http://store.steampowered.com/app/234270/\"><img src=\"https://steamcdn-a.akamaihd.net/steam/apps/234270/capsule_467x181.jpg\" style=\" float: left; margin-right: 12px; height: 181px; width: 467px;\"></a>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}