re = /\/(.*)[^\/]$/m
str = '/admissions/dual/index.html
/admissions/dual/index.html/
/apply/index.html/
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end