#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)(?<= \s )" & @CRLF & _
" # Match opening braket (i.e., `[`)." & @CRLF & _
" ( \[ )" & @CRLF & _
"" & @CRLF & _
" # Match any single character (e.g., `x`)." & @CRLF & _
" ( . )" & @CRLF & _
"" & @CRLF & _
" # Matching closing braket (i.e., `]`)" & @CRLF & _
" ( \] )" & @CRLF & _
"(?= \s* [?!*]? \s* )" & @CRLF & _
"" & @CRLF & _
"# Exclude entries without text (i.e., incl. in tables)." & @CRLF & _
"(?! " & @CRLF & _
" \s* [?!*]? \s* \|" & @CRLF & _
" |" & @CRLF & _
" \s* [?!*]? \s* $" & @CRLF & _
")" & @CRLF & _
"" & @CRLF & _
"# Match the text (i.e., capture based on modifier presence)." & @CRLF & _
"(?:" & @CRLF & _
" # Match modifier (i.e., `!`, `?`, or `*`) and the text that follows." & @CRLF & _
" \s* ( [!?*] ) \s* ( .*? )" & @CRLF & _
" |" & @CRLF & _
" # Match the text that does not follow a modifier." & @CRLF & _
" \s* (?! [!?*]) \s* ( .*? )" & @CRLF & _
")" & @CRLF & _
"# Match until either of the stops that follow are met." & @CRLF & _
"(?= \s+ \^[a-z0-9]{6,} | \s+ \| | \s*$)"
Local $sString = "# Should match" & @CRLF & _
"" & @CRLF & _
"- [ ] Some task" & @CRLF & _
"- [ ] Some task | [[link]]" & @CRLF & _
"- [ ] Some task ^abcdef" & @CRLF & _
"- [ ] Some task | [[link]] ^abcdef" & @CRLF & _
"- [ ] ! Some task" & @CRLF & _
"- [ ] ! Some task | [[link]]" & @CRLF & _
"- [ ] ! Some task ^abcdef" & @CRLF & _
"- [ ] ! Some task | [[link]] ^abcdef" & @CRLF & _
"- [ ] Task one | [ ] ! Task two | [ ] Task three ^abcdef" & @CRLF & _
"" & @CRLF & _
"| Tracker | Task | Backlog |" & @CRLF & _
"| ----------: | :---------------------- | :------- |" & @CRLF & _
"| 00:00-00:00 | [ ] Task item | [[linK]] |" & @CRLF & _
"| 00:00-00:00 | [ ] Task item ^abcdef | [[link]] |" & @CRLF & _
"| 00:00-00:00 | [ ] [[task-item]] | [[link]] |" & @CRLF & _
"| 00:00-00:00 | [ ] ! Task item | [[linK]] |" & @CRLF & _
"| 00:00-00:00 | [ ] ! Task item ^abcdef | [[link]] |" & @CRLF & _
"| 00:00-00:00 | [ ] ! [[task-item]] | [[link]] |" & @CRLF & _
"" & @CRLF & _
"# Should not match" & @CRLF & _
"" & @CRLF & _
"- [ ] " & @CRLF & _
"- [ ]" & @CRLF & _
"- [ ] " & @CRLF & _
"- [ ] ! " & @CRLF & _
"- [ ] !" & @CRLF & _
"- [ ] ! " & @CRLF & _
"" & @CRLF & _
"| Tracker | Task | Backlog |" & @CRLF & _
"| ----------: | :---------------------- | :------- |" & @CRLF & _
"| 00:00-00:00 | [ ] | [[linK]] |" & @CRLF & _
"| 00:00-00:00 | [ ] ! | [[linK]] |" & @CRLF & _
"" & @CRLF & _
"# Desired outcome" & @CRLF & _
"" & @CRLF & _
"- group `notation`:" & @CRLF & _
" - match: `[` and `]`" & @CRLF & _
"" & @CRLF & _
"- group `symbol`: " & @CRLF & _
" - match: any single character (e.g., `\s`) between `[` and `]`" & @CRLF & _
"" & @CRLF & _
"- group `modifier`:" & @CRLF & _
" - match: `!`, `?`, or `*` that follows after `[ ]`" & @CRLF & _
"" & @CRLF & _
"- group `text`: " & @CRLF & _
" - match: task text after `[ ]` without modifier present" & @CRLF & _
"" & @CRLF & _
"- group `textmod`: " & @CRLF & _
" - match: task text after `[ ] !` with modifier present" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")