import re
regex = re.compile(r"^(?:[+]6)?0(([0-9]{2}((\s[0-9]{3,4}\s[0-9]{4})|(-[0-9]{3,4}\s[0-9]{4})|(-[0-9]{7,8})))|([0-9]{9,10}))$", flags=re.MULTILINE)
test_str = ("01234567890\n"
"+601234567890\n\n"
"012-34567890\n"
"+6012-34567890\n\n"
"012-3456 7890\n"
"+6012-3456 7890\n\n"
"012 3456 7890\n"
"+6012 3456 7890\n\n"
"#invalid:\n\n"
"0122 3456 7890\n"
"12 3456 7890\n"
"+60122 3456 7890\n"
"012345678900\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")