re = /((?:.){2,})/
str = 'word boundaries are odd
\\n
\\n\\n
\\n\\n\\n
\\n \\n
\\n \\n \\n
\\n \\n
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end