$re = '/(\d+)[^\d]+someword/m';
$str = '43434 of someword 12 anything someword 2323 new someword.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);